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Configuring Eclipse For Python

Before you configure the Eclipse IDE for Python, you must
first have Python installed on your system.

As indicated in the first part of the Python notes, there are
typically a couple of current Python environments. You’ll
need to select one of these for the Eclipse environment
during the setup (if you have more than one Python
environment installed).

Obviously, you also need to have Eclipse installed on your
system before starting this sequence as well. I’m illustrating
this using the Eclispe IDE which is known as Helios.

To configure Eclipse for Python follow the steps beginning
on the next page.
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Configuring Eclipse For Python

| imagine that most of you probably have your default
Eclipse environment set for a Java perspective which will
look something like the screenshot on the next page
depending on how you’ve customized your Java perspective.

From this main screen is where you’ll begin the process of
Installing the Python development environment.

From the Java perspective, go to Help > Install New
Software. You’ll see the window that appears on page 5.
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— Java - Final Exam - Summer 2011/src/Fruitjava - Eclipse =k
File Edit Source Refactor Mavigate Search Project Bun Window Help

mifdli= = F-O0-Q- HG- E@®@c s~ PHs E [N 5 (& Java |
T!}I - i}' * (::l v oo or ‘r
i = AT . . . . - £ =] ™
£ Package Explorer &3 B[ 5 Consume.java (m Applejava (m Orange.java ﬂzl Hungry.java ﬂzl Fruitjava &2 33 |
Fl R e ERlaS LJ'—FJ-\-IJJ-I'IMJ-EIII-J E
B&| 6 o
=¥ Abstract Classes protected Fruit() { ==
2! Basic Java normalColor="red";
typicalWeight = 4; ‘ =

:Lf,J- Classes In Java

:Lf,J- Day Two

'[,f,,J- Exam 1 - Surmmer 2011
:L';‘J Exam 2 - Summer 2011
:L';‘J Exception Handling

}

protected Fruit(String a, int b){
normalColor=a;
typicalWeight=b;

h

protected String getColor(){

Notice the Java
perspective is
active

:L.?d File IO return normalColor;

bﬁj, Final Exam - Summer 2011 }

:Ijj GUls protected int getWeight(){

122 In Class Practice #1 return typicalleight;

=2 In Class Practice £2 ¥ E

= protected vold setColor(String a){

-
i Interfaces this.normalColor = a;)

=2 Loan Project 3
=2 Methods In Java = protected void setWeight(int a) {
14 My First Java Programs this.typicalWeight=a;

v - 1

;'-f_/d' Nem’“rk'”g = public String toString() {

L Program Five return ("This fruit is normally " + normalColor +

iz Program Four " and typically weighs about " + typicalWeight + " ocunces. ");
= Program Cne 1

:Lf/J, Program Three protected abstract String bestUse();

N
L’__j Pr!:bgram.Two. //public abstract String howToEat(); i
iz Wind Chill Project 1

0¥ Writable Smart Insert 21:30 g o @ [B g E
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| = Install

Available Software

Select a site or enter the location of a site.

Work with:  type or select a site

type filter text

Mame
[[] (@) There is no site selected.

Find more software by working with the "Available Software Sites” preferences,

=)

s

: 2. Click Add

- Add...

Yersion 3 .

When you Click Add in #2, this
pop-up will appear. Enter:
http://pydev.org/updates
under Location and click OK.

‘|| Select{ = Add Repository /

S5

Details Mame: /

Local...

Location:  http://pydev.org/updates

Show o
Group it

Archive...

: [7] Show o @ [ -

J

Cancel l

[V] Contact e apasee e rrrarr o rrrrerreerr e —oreraTe

©)
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| = Install

Available Software
Check the itermns that you wish to install,

Work with:  http://pydev.org/updates

Find more software by working with the "Available Software Sites” preferences,

type filter text

Mame Yersion
Pl 000 PyDev

L PyDev for Eclips 2.24.2011110216
. [] 000 PyDev Mylyn Integration (op

4. Back in the Available Software
window, select the “pyDev” option.
Do not select the “PyDev Mylyn

Select All | | Deselect Al 1 item selected Integration” option.

Details

PyDev

More...

Show only the latest versions of available software [T Hide items that are already installed
Group items by category What is already installed?

‘ [ Show only software applicable to target environment

[¥] Contact all update sites during install to find required software
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| = Install

Available Software
Check the itermns that you wish to install,

Work with:  http://pydev.org/updates

Find more software by working with the "Available Software Sites” preferences,

type filter text

Mame Yersion
Pl 000 PyDev

L PyDev for Eclipse 2.24.2011110216
. [ 000 PyDev Mylyn Integration (o

Back in the Available Software
window, select the “pyDev” option.
Select All | [ Deselect Al 1 item selected Do not select the “PyDev Mylyn
Integration” option.

Details

PyDev

More...

Show only the latest versions of available software [T Hide items that are already installed

Group items by category What is already installed?

[ Show only software applicable to target environment 5 CI|Ck Next
[¥] Contact all update sites during install to find required software
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- - I " - - I

— Install

Install Details

Review the iterms to be installed.

Mame
% PyDev for Eclipse

Yersion
2242011110216

Id
org.python.pydev.feature.feature.group

6. Be sure that PyDev for Eclipse is
highlighted (selected).

4 |

I

Size: 7,296 KB
Details

Python Development Environment

7. Click Next.

/
<Back || Net>¥® || Einisn
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| = Install

Review Licenses

Licenses must be reviewed and accepted before the software can be installed.

License text (for PyDev for Eclipse 2.2.4,2011110216):
Eclipse Public License - v1.0

THE ACCOMPANYING PROGRAM IS PROVIDED UMDER THE TERMS OF THIS ECLIPSE PU
REPRODUCTION OR DISTRIBUTION OF THE PROGRAM COMSTITUTES RECIPIEMT'S ACC

1. DEFIMITIOMNS
"Contribution” means:

a) in the caze of the initial Contributor, the initial code and documentation
k) in the case of each subsequent Contributor:

ijchanges to the Program, and

iijadditions to the Program;

where such changes and/or additions to the Program criginat
Contribution 'originates’ from a Contributor if it was added to
Contributor's behalf, Contributions do not include additions
distributed in conjunction with the Program under their o
"Contributor” means any person or entity that distribut

the Program.

"Licensed Patents " mean patent claims licensable
Contribution alone or when combined with the Ppfgram.

@ i accept the terms of the license agreement;

(71 I do not accept the terms of the license agreement

@

8. Be sure read all of this (yeah right!)
Then select “l accept...”

stributed under this Agreement, and

rom and are distributed by that particular Contributor, A

e Program by such Centributor itself or anyone acting on such
the Program which: (i) are separate modules of software

license agreement, and (i} are not derivative works of the Program,

a Contributor which are necessarily infringed by the use or sale of its

9. Click Finish.

Finish J [ Cancel
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- = Selection Meeded

Do you trust these certificates?

10. Click “Select All”

[] iAptana Pydev; Pydev; Aptanai

ﬁnce you click OK, \

4 Eclipse will ask you to

| SelectAll || DeselectAll | restart.

Aptana Pydewv, Pydev: Aptana

Aptana Pydev; Pydev; Aptana / 1 1 . C||Ck OK Restart Ec|ipse now.

Go to the next page to
configure the Python
@ | Cancel | [ development

anironment. /
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Ay -
= Java - Final Exam - Summer 2011/src/Fruit.java - Eclipse
File Edit Source Refactor Mavigate Search Project Bun Window Help

$5-0-Q\¥ G- E®c v~ P ET 5 [T Tmva )
& v

Km Consume,java (m Apple.j% (m Orange.java (m Hungry.java (m Fruit.java 2

Fravuee L ey Pl

12 Abstract Classes protected Fruit() {
'[jj- Basic Java
:L';‘J ClassesIn Java 1

normalColor="red";
typicalWeight = 4;

:szj‘ Day Twe protected Fruit(string a,

=2 Exam 1 - Summer 2011 normalColor=a; 12 GOt tO WlndOW > Preferences

"= Exam 2 - Summer 2011 typicalWeight=b;
h
protected String getColor(){

return normalColor;

:Lj',J Exception Handling
1= File10

b;—‘,J- Final Exam - Summer 2011 }

:Lj',J GUIs protected int getWeight(){
=% In Class Practice #1 return typicalileight;

W S }
& In Class Practice £2 protected void setColor(String a){

N
i Interfaces this.normalColor = aj;

=4 Loan Project }
=2 Methods In Java protected void setWeight(int a) {
[=2 My First Java Programs this. typicalWeight=a;

v - 1
i Netwarking public String teString() {

| return ("This fruit is normally °
= Program Four " and typically weighs about "
=4 Program One 1

:Lf/J, Program Three protected abstract String bestUse();

=4 Program Two
"= Wind Chill Project

:Lff- Program Five

+ normalColor +
+ typicalWeight +

ounces. ");

{/public abstract String howTeEat();

Writable Smart Insert 21:30
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t_-,prfiIter text PIDQ'“' - - v
» General

- Ant
> Help Hesturegefaultsl [ Apply

Install/Update

PyDev version: 2.2.4.2011110216

Java
Mawven

H
kS
&
= Wylyn
4

Py e

Eu!ders 13. In the Preferences window,
Eug

Editor expand Pydev and select

Interactive Console “I nterpreter_Pythonu
Interpreter - Iran Python

Interpreter - lython /

Interpreter - Python
Logging
PyLint
PyUnit
Scripting PyDev
Task Tags
Fun/Debug
Team

Usage Data Collector
Validation
WindowBuilder

XML

@ Cancel |

N e e [
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= Preferences

type filter text

+ General
» Ant
» Help
» Install/Update
» lava
» Maven
> Mylyn
a PyDev
Builders
> Debug
: Editor
Interactive Conscle
Interpreter - Iren Pythen

Python Interpreters

Mame

Python interpreters (e.ge python.exe)

| ocaticn

14. Click New

Aute Config

Remaove

=i Libranes

Forced Builtins | Predefined | E Environment

Systern PYTHOMNPATH

Enter the name and executable of your interpreter

Interpreter Name:

Interpreter Executable:

Python33

ChPython3python.exe

Cancel

15. In the Select Interpreter

dialog enter Python33 for the
Interpreter Name. (I'm
assuming you downloaded
the latest version of Python
which is 3.3.2, otherwise
enter the appropriate name.)

For the Interpreter
Executable, browse to
your location of
Python.

Click OK.

] l lL_ancel ]

CNT 4603: Configuring Eclipse For Python

Page 13

Dr. Mark Llewellyn ©




Select the folders to be added to the SYSTEM pythenpath!

IMPORTANT: The folders for your PROJECTS should NOT be added here, but in your project configuration.

Check:http://pydev.org/manual_101_interpreter.html for more details.

[] &l iC:\Users\Mark Llewellyn'.eclipse\org.eclipse.platform_4.3.0 867647348 win32 win32 xB6_64\pl

[] & C\Windows\SYSTEM32\python33.zip
& C:\Python33\DLLs

&) C:\Python33\lib -
& C:\Python33
& C:\Python33\lib\site-packages

/

16. In the Selection needed
dialog, select all but the
PySrc and python33.zip and
select OK. (These are
probably already auto
selected, but be sure.)

Select All not in Workspace Select All select A

Cancel

17. Click OK as many times as
necessary to exit the
preferences.

18.You’re now ready to go!
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— Open Perspedive—E@ﬁ-

Bacvs Repository Exploring
ﬁ?DEhug

|11, Git Repository Exploring
& Java (default)

E,’Java Browsing
J 1 . ] .

18 Java Type Hierarchy 19. Back in the main Eclipse
2 Planning . :

window, go to Window >
Open Perspective > Other
£0Team Synchronizing and choose PyDeV, then
X XML click OK.

0K | ‘ Cancel
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— PyDev - Eclipze

File Edit MNawvigate 5&arsh Project Pydev Bun  Window Help
r9 - o~ ® F-Q-QU- B H HE e o =

™ fD_ .
o= Outlige 2

R

ftg PyDev Package Explorer &3 =0
= %| -+, =

S

An outling is not available.

\
Notice the PyDev
(Python)
perspective is now
active.

E_L, Problems @2

0 items

Description Rescurce Location Type

| b

a0 BE® <
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File Edit Source Refactoring MNavigate Search Project Pydev Run Window Help
IR AENENEE B TR R R R SR E R A B | Quick Access |;jﬁ|ayjaua

f# PyDevPackage Explorer i3 = 0 [ GuestDataBea... [J] GuestBeanjava [J] GuestBeanjava [J] GuestDataBea... [F] python-part1... 32 | ¥z = 0

—+l, = (=
&% Ll
Created on Noy 4, 2813

4 ﬁ Python Code
I python-part1-pagell.py fauthor: Mark [lewellyn
I Python33 (CA\Python3dpython.exe) ree .

B E'ianb;ttuff : ” print("Helle World") ECIIpse In A Python

» 2 Bowman Pr%ntémh Perspective

» & CNT 4714 - JDBC Notes print{(s/4)

b 124 Project Five - Fall 2013

b 124 Project Four - Fall 2013

b 124 Project One - Fall 2013

b 124 Project Three - Fall 2012

b 124 Project Two - Fall 2013

[ E' servlet examples

b & TAZ

B Console & -x&%ﬁ||5h5§|ﬂﬁ‘fﬁ‘=ﬁl
<terminated> C\Users\Mark Llewellyn\workspace\CNT 4714\Python Code\python-part1-page10.py

Hello World

5

2.8

‘ Writable | Insert ‘ 8:11
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